Android Studio – Emulator not running

I am getting the error “the emulator process for avd was killed” and I have researched questions on this side with similar issues and tried things like reinstalling haxm and running a fresh install of android studio.

Here are the logs, please can someone educate me I’m so frustrated

2020-10-16 17:08:00,561 [   1348]   INFO - gs.impl.UpdateCheckerComponent - channel: release 
2020-10-16 17:08:00,628 [   1415]   WARN - nSystem.impl.ActionManagerImpl - keymap "ReSharper" not found [Plugin: com.android.tools.ndk] 
2020-10-16 17:08:00,648 [   1435]   WARN - nsions.impl.ExtensionPointImpl - Extension to be removed not found: class org.jetbrains.plugins.gradle.execution.test.runner.TestClassGradleConfigurationProducer 
2020-10-16 17:08:00,762 [   1549]   WARN - Container.ComponentManagerImpl - Do not use constructor injection (requestorClass=com.android.tools.idea.apk.symbols.DebugSymbolNotifications) 
2020-10-16 17:08:01,200 [   1987]   INFO - rd.FirstRunWizardFrameProvider - Overriding welcome frame to be resizable 
2020-10-16 17:08:06,410 [   7197]   INFO - manager.EmulatorProcessHandler - Emulator: C:UsersCianAppDataLocalAndroidSdkemulatoremulator.exe -netdelay none -netspeed full -avd Pixel_4 
2020-10-16 17:08:06,427 [   7214]   INFO - roid.tools.idea.adb.AdbService - Initializing adb using: C:UsersCianAppDataLocalAndroidSdkplatform-toolsadb.exe 
2020-10-16 17:08:06,439 [   7226]   INFO - manager.EmulatorProcessHandler - Emulator: emulator: ERROR: Unknown AVD name [Pixel_4], use -list-avds to see valid list. 
2020-10-16 17:08:06,439 [   7226]   INFO - manager.EmulatorProcessHandler - Emulator: ANDROID_SDK_HOME is defined but there is no file Pixel_4.ini in $ANDROID_SDK_HOMEavd 
2020-10-16 17:08:06,439 [   7226]   INFO - manager.EmulatorProcessHandler - Emulator: (Note: Directories are searched in the order $ANDROID_AVD_HOME, $ANDROID_SDK_HOMEavd and $HOME.androidavd) 
2020-10-16 17:08:06,440 [   7227]   INFO - manager.EmulatorProcessHandler - Emulator: Process finished with exit code 1 
2020-10-16 17:08:06,441 [   7228]   WARN - manager.EmulatorProcessHandler - Emulator terminated with exit code 1 
2020-10-16 17:08:08,508 [   9295]   WARN -            #com.android.ddmlib - * daemon not running; starting now at tcp:5037 
2020-10-16 17:08:08,529 [   9316]   WARN -            #com.android.ddmlib - * daemon started successfully 
2020-10-16 17:08:08,537 [   9324]   INFO -            #com.android.ddmlib - Connected to adb for device monitoring 
2020-10-16 17:08:08,736 [   9523]   INFO - roid.tools.idea.adb.AdbService - Successfully connected to adb 

Edited Logs

2020-10-16 18:12:02,605 [ 881852]   INFO - manager.EmulatorProcessHandler - Emulator: C:UsersCianAppDataLocalAndroidSdkemulatoremulator.exe -netdelay none -netspeed full -avd Pixel_4_XL_API_30 
2020-10-16 18:12:02,631 [ 881878]   INFO - manager.EmulatorProcessHandler - Emulator: emulator: ERROR: Unknown AVD name [Pixel_4_XL_API_30], use -list-avds to see valid list. 
2020-10-16 18:12:02,631 [ 881878]   INFO - manager.EmulatorProcessHandler - Emulator: ANDROID_SDK_HOME is defined but there is no file Pixel_4_XL_API_30.ini in $ANDROID_SDK_HOMEavd 
2020-10-16 18:12:02,631 [ 881878]   INFO - manager.EmulatorProcessHandler - Emulator: (Note: Directories are searched in the order $ANDROID_AVD_HOME, $ANDROID_SDK_HOMEavd and $HOME.androidavd) 
2020-10-16 18:12:02,631 [ 881878]   INFO - manager.EmulatorProcessHandler - Emulator: Process finished with exit code 1 
2020-10-16 18:12:02,631 [ 881878]   WARN - manager.EmulatorProcessHandler - Emulator terminated with exit code 1 
2020-10-16 18:12:32,480 [ 911727]   INFO - manager.EmulatorProcessHandler - Emulator: C:UsersCianAppDataLocalAndroidSdkemulatoremulator.exe -netdelay none -netspeed full -avd Pixel_4_XL_API_30 
2020-10-16 18:12:32,506 [ 911753]   INFO - manager.EmulatorProcessHandler - Emulator: emulator: ERROR: Unknown AVD name [Pixel_4_XL_API_30], use -list-avds to see valid list. 
2020-10-16 18:12:32,506 [ 911753]   INFO - manager.EmulatorProcessHandler - Emulator: ANDROID_SDK_HOME is defined but there is no file Pixel_4_XL_API_30.ini in $ANDROID_SDK_HOMEavd 
2020-10-16 18:12:32,506 [ 911753]   INFO - manager.EmulatorProcessHandler - Emulator: (Note: Directories are searched in the order $ANDROID_AVD_HOME, $ANDROID_SDK_HOMEavd and $HOME.androidavd) 
2020-10-16 18:12:32,506 [ 911753]   INFO - manager.EmulatorProcessHandler - Emulator: Process finished with exit code 1 
2020-10-16 18:12:32,506 [ 911753]   WARN - manager.EmulatorProcessHandler - Emulator terminated with exit code 1 

Answer

ANDROID_SDK_HOME is defined but there is no file Pixel_4.ini in $ANDROID_SDK_HOMEavd

it seems you have configured an emulator without an image or the image might have been delted later.

all you have to do is download a valid emulator image and then reconfigure emulator and after that you can expect things to work properly

[EDIT]: based on update in question

there are two important messages in log

  • Unknown AVD name [Pixel_4_XL_API_30], use -list-avds to see valid list
  • ANDROID_SDK_HOME is defined but there is no file Pixel_4_XL_API_30.ini in $ANDROID_SDK_HOMEavd

in the first error it seems the the emunlator is not running so the error is about that

in second error there might be some path mismatch due to which the image is not found by the emulator before running.

so you check manually at path $ANDROID_SDK_HOMEavd do you see your emulator images ? then comment back