Error: The apk for your currently selected variant (Unknown output) is not signed. Please specify a signing configuration for this variant (debug)

After upgrading to Android Studio Arctic Fox (2020.3.1) Canary 9. I cannot run my tests. It pops up the Edit Configurations window to show Error: The apk for your currently selected variant (Unknown output) is not signed. Please specify a signing configuration for this variant (debug). message. I can’t seem to solve this issue just by creating .jks and use the release signing configuration for debug variant as well like most of the posts suggested. I kinda stuck between whether I downgrade or try to solve it somehow. Is there anyone who faced this issue before? Any suggestions and opinions are welcomed.

enter image description here

Problem still occurs in Android Studio Arctic Fox (2020.3.1) Canary 10 version as well.

Answer

The problem occurs if Android Gradle Plugin (AGP) is higher than 7.0.0-alpha08. So downgrading to 7.0.0-alpha08 solves the problem. By doing so, you must also downgrade to Android Studio Arctic Fox (2020.3.1) Canary 8 because later versions require their corresponding AGP or the latest one. I’m not happy with the downgrade solution. But this is the only way for the tests to run at the moment.

Android Studio Archieves

Leave a Reply

Your email address will not be published. Required fields are marked *