GoogleApiAvailability missed with firebase-messaging:9.4.0

Declaring dependencies as

compile 'com.google.firebase:firebase-messaging:9.4.0'

I get “can not resolve symbol GoogleApiAvailability” message in the activity’s import row

import com.google.android.gms.common.GoogleApiAvailability;

What is wrong?

  • not question’s duplicate: Google Play Services are already on the latest version

Answer

Add this line to your build file dependencies:

compile 'com.google.android.gms:play-services-base:9.4.0'

play-services-base is the Play Services base client library and is listed in the Play Services Setup Guide.