How to create NotificationChannel for lower API’s ( < 26 ) ?

How to create NotificationChannel for lower API’s ( < 26 )?. Is there some way to do it with AppCompat?

Answer

Not possible. The Android OS does not support it. You can add the channelId to the notification with NotificationCompat.Builder(Context context, String channelId), but the OS will ignore it pre-Oreo.

My collegue tested it on API 15, 22, 23, and 26: https://stackoverflow.com/a/45979726/1310343