Unable to resolve dependency tree error when installing npm packages

When trying to install the npm packages using npm i command I am getting the following exception:

enter image description here

I have tried reinstalling the node js package and setting proxy to off using:

set HTTP_PROXY=
set HTTPS_PROXY=

The issue is still there. What I am doing wrong?

Update:

When I run the following command:

npm install --legacy-peer-deps

The following error is displayed: enter image description here

Answer

This is not related to http proxy.

You have dependency conflict (incorrect and potentially broken dependency) as it says, So try to to run the command with --force, or --legacy-peer-deps. If it doesn’t take effect, the temporary solution is using prior versions of the node (Downgrading node version) as it causes to happen such this errors sometimes.

Update based on OP’s Update:

As you see, it fires the following error :

No matching version found for @angular/[email protected]^9.1.4.

Take a look at angular/http page. Note that the latest version for that deprecated package is 7.2.16 while you request an upper version (e.g ^9.1.4)! So, try to check the project dependencies and follow the raised errors in order to solve the problem.