Conda MacOS Big Sur ld: unsupported tapi file type ‘!tapi-tbd’ in YAML file

When compiling a c++ project in a conda environment on MacOS Big Sur, the error ld: unsupported tapi file type '!tapi-tbd' in YAML file may occur. How to proceed?

Answer

On Big Sur, the SDK that comes with Command Line Tools is too new. An older one needs to be downloaded and used:

  1. Download the 10.10 SDK “MacOSX10.10.sdk.tar.xz” from here.
  2. Extract it: tar xf MacOSX10.10.sdk.tar.xz -C /opt
  3. Add following lines to ~/.condarc:
conda_build:
  config_file: ~/.conda/conda_build_config.yaml
  1. create ~/.conda/conda_build_config.yaml if it doesn’t exist and add:
CONDA_BUILD_SYSROOT:
  - /opt/MacOSX10.10.sdk        # [osx]

Many thanks to ihnorton on this thread.