sequelize.js – You need to install mysql package manually

After installing node.js and sequelize.js, and running a basic test, the message “You need to install mysql package manually” is displayed.

I’ve tried searching the web and Stackoverflow for the cause of this message.

I have installed:

  • mysql server version 5.5.31-0ubuntu0.13.04.1
  • node v0.10.5
  • sequelize.js v1.6.0

Answer

You need to install the mysql npm module:

npm install mysql

The reason sequelize doesn’t have the mysql module as its own dependency is because it can be used with other databases such as postgres or sqlite.

Leave a Reply

Your email address will not be published. Required fields are marked *