Eclipse libgdx import cannot be resolved

I am following this tutorial http://steigert.blogspot.com/2012/02/3-libgdx-tutorial-scene2d.html and i get an error in eclipse for these imports:

import com.badlogic.gdx.scenes.scene2d.OnActionCompleted;
import com.badlogic.gdx.scenes.scene2d.actions.Delay;
import com.badlogic.gdx.scenes.scene2d.actions.FadeIn;
import com.badlogic.gdx.scenes.scene2d.actions.FadeOut;
import com.badlogic.gdx.scenes.scene2d.actions.Sequence;
import com.badlogic.gdx.scenes.scene2d.ui.Align;
import com.badlogic.gdx.scenes.scene2d.ui.Image;
import com.badlogic.gdx.scenes.scene2d.ui.Image.Scaling;

all other libgdx imports work fine but these give me the import cannot be resolved error

does anyone of you know how to fix this?

Answer

Now that I can see my code, yes – the libgdx version used in the steigert demos is not the latest, and lots of scene2d has changed since then.

http://steigert.blogspot.com/2012/07/13-libgdx-tutorial-libgdx-refactoring.html

You can get his refactored/updated code at:

https://code.google.com/p/steigert-libgdx/source/browse/tags/

Leave a Reply

Your email address will not be published. Required fields are marked *