Eclipse Oxygen JVM Error

I’m just getting back to java, and went and downloaded the latest Eclipse Oxygen. Once it’s all installed, I try to launch and get the following error dialogue.

Incompatible JVM

So I went and downloaded Java 8 and installed that. Once again I tried to open Eclipse. It still displays the exact same answer. Any idea on how to fix this?

Answer

On macOS you must install the full JDK – the JRE install isn’t enough.

Get the full JDK from the Oracle site here.

If you install Java 9 you will need to use at least Eclipse Oxygen.1a (4.7.1a) but preferably the current Eclipse, for eariler versions of Eclipse install Java 8.

Leave a Reply

Your email address will not be published. Required fields are marked *