Sbt resolve wrong version of library

What’s wrong with sbt? It is resolve wrong version of transient dependency.

In reposytory pom library mark with specific version but sbt tries to download this:

https://repo1.maven.org/maven2/org/jboss/spec/javax/servlet/jboss-servlet-api_3.1_spec/working@theSemenovPC/jboss-servlet-api_3.1_spec-working@theSemenovPC.pom

Where they find working@theSemenovPC? Why it not resolves to 1.0.2.Final as specified in pom?

upd: build.sbt

name := "test-sbt"

version := "0.1"

scalaVersion := "2.12.8"

libraryDependencies += "org.keycloak" % "keycloak-services" % "4.5.0.Final"

output:

...
info] Defining Global / sbtStructureOptions, Global / sbtStructureOutputFile and 1 others.
[info] The new values will be used by cleanKeepFiles
[info]  Run `last` for details.
[info] Reapplying settings...
[info] Set current project to test-sbt (in build file:/home/thesemenov/projects/kredo-beckend-runner/git/twst-sbt/)
[info] Applying State transformations org.jetbrains.sbt.CreateTasks from /home/thesemenov/.IdeaIC2018.3/config/plugins/Scala/launcher/sbt-structure-1.0.jar
[info] Reapplying settings...
[info] Set current project to test-sbt (in build file:/home/thesemenov/projects/kredo-beckend-runner/git/twst-sbt/)
[info] Updating ...
[warn]  module not found: org.jboss.spec.javax.xml.bind#jboss-jaxb-api_2.3_spec;working@theSemenovPC
[warn] ==== local: tried
[warn]   /home/thesemenov/.ivy2/local/org.jboss.spec.javax.xml.bind/jboss-jaxb-api_2.3_spec/working@theSemenovPC/ivys/ivy.xml
[warn] ==== public: tried
[warn]   https://repo1.maven.org/maven2/org/jboss/spec/javax/xml/bind/jboss-jaxb-api_2.3_spec/working@theSemenovPC/jboss-jaxb-api_2.3_spec-working@theSemenovPC.pom
[warn] ==== local-preloaded-ivy: tried
[warn]   /home/thesemenov/.sbt/preloaded/org.jboss.spec.javax.xml.bind/jboss-jaxb-api_2.3_spec/working@theSemenovPC/ivys/ivy.xml
[warn] ==== local-preloaded: tried
[warn]   file:////home/thesemenov/.sbt/preloaded/org/jboss/spec/javax/xml/bind/jboss-jaxb-api_2.3_spec/working@theSemenovPC/jboss-jaxb-api_2.3_spec-working@theSemenovPC.pom
[warn]  module not found: org.jboss.spec.javax.servlet#jboss-servlet-api_3.1_spec;working@theSemenovPC
[warn] ==== local: tried
[warn]   /home/thesemenov/.ivy2/local/org.jboss.spec.javax.servlet/jboss-servlet-api_3.1_spec/working@theSemenovPC/ivys/ivy.xml
[warn] ==== public: tried
[warn]   https://repo1.maven.org/maven2/org/jboss/spec/javax/servlet/jboss-servlet-api_3.1_spec/working@theSemenovPC/jboss-servlet-api_3.1_spec-working@theSemenovPC.pom
[warn] ==== local-preloaded-ivy: tried
[warn]   /home/thesemenov/.sbt/preloaded/org.jboss.spec.javax.servlet/jboss-servlet-api_3.1_spec/working@theSemenovPC/ivys/ivy.xml
[warn] ==== local-preloaded: tried
...

Answer

I found the answer for a similar question: sbt: error importing resteasy-client

It seems that sbt can’t resolve transient dependencies without version in pom to the latest version. You need to exclude that library from transient and include it into project libraryDependencies with the specified version by hand