spring tools 3(standalone) 3.9.14 version release An internal error occurred during: “Loading Spring static imports into Eclipse code assist favorite

I installed spring tool 3 standalone from Eclipse marketplace after restart getting this error i got this error when i start my eclipse, I get the errors,

An internal error occurred during: "Initializing Java Tooling".
org/eclipse/jdt/core/search/SearchPattern$AjcClosure1

and

An internal error occurred during: "Loading Spring static imports into Eclipse code assist favourites"
.org/eclipse/jdt/internal/compiler/parser/Scanner$AjcClosure1

I am using Eclipse latest 2021-09 and java version 16

Answer

Spring Tools 3 (Standalone Edition) 3.9.14 is not supported anymore and is not compatible with the latest Eclipse 2021-09 release. The entry on the Eclipse marketplace is flagged as available for Eclipse 2020-09 as the latest.

We do provide Spring Tools 3 distribution builds for newer Eclipse versions, but since they are not supported anymore for a long time now, those are not well tested. If you urgently need that version, you can get them from here: https://github.com/spring-projects/toolsuite-distribution/wiki/Spring-Tool-Suite-3

Nevertheless, I highly recommend to use Spring Tools 4 for Eclipse instead – and file an issue if you are missing a specific feature from Spring Tools 3 in there and prevents you from upgrading.