ReactJS – Preferred convention for prop naming

I wonder what is preferred prop naming convention by ReactJS community ?

<TodoList todos={todos} onRemoveTodo={removeTodo} onCheckTodo={checkTodo} />


<TodoList items={todos} onRemoveItem={removeTodo} onCheckItem={checkTodo} />

or any other way ??



I don’t think there is an iron-clad convention for naming props. You can look at the following articles:

It ultimately depends on you, your team and how well you can document for both you and other developers on the project.