Why did NPM stopped working after an update?

2 Days ago I Updated NPM and yesterday I realized that it stopped working.

My platform is Windows 10 20H2.

Every single thing I do gives me the same error.

C:Usersethan>npm
internal/modules/cjs/loader.js:883
  throw err;
  ^

Error: Cannot find module 'code-point-at'
Require stack:
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugenode_modulesstring-widthindex.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugewide-truncate.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugerender-template.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugeplumbing.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugeindex.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesnpmloglog.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmlibcli.js
- C:UsersethanAppDataRoamingnpmnode_modulesnpmbinnpm-cli.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:880:15)
    at Function.Module._load (internal/modules/cjs/loader.js:725:27)
    at Module.require (internal/modules/cjs/loader.js:952:19)
    at require (internal/modules/cjs/helpers.js:88:18)
    at Object.<anonymous> (C:UsersethanAppDataRoamingnpmnode_modulesnpmnode_modulesgaugenode_modulesstring-widthindex.js:3:19)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Module.require (internal/modules/cjs/loader.js:952:19) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\gauge\node_modules\string-width\index.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\gauge\wide-truncate.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\gauge\render-template.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\gauge\plumbing.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\gauge\index.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\node_modules\npmlog\log.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\lib\cli.js',
    'C:\Users\ethan\AppData\Roaming\npm\node_modules\npm\bin\npm-cli.js'
  ]
}

I’ve already tried reinstalling node and NPM but it didn’t worked.

What should I do and why did this happened? Please help me with this, Thanks.

Answer

Its me, I Finished using Ubuntu WSL for getting the attachment link of the missing dependencies, Thank you for your help @JSON Derulo @speciesUnknown.

Leave a Reply

Your email address will not be published. Required fields are marked *